[Wannier] WG: Wannier examples crash with segmentation fault

Jonathan Yates jonathan.yates at materials.ox.ac.uk
Mon Mar 19 23:10:57 CET 2012

On 19 Mar 2012, at 17:25, Kristof Karhan wrote:

> Dear all,
> I have tried to install wannier90 as an Extension to Quanutm Espresso 4.3.2.
> The installation itself seems to go well ( see the output of make below)
> , but when I run the example calculations, test1 exits with a segmentation fault (see below), whereas test2 fails because of wrong eigenvalues.
> I have attached the files wantest.log, and the wannier.wout files of both tests. The system I work on is a Intel Westmere/Woodcrest computer cluster with
> PU_IAS Linux operating system
> (More Information on Hardware: http://www.princeton.edu/researchcomputing/computational-hardware/machine-2/
> And on software: http://www.princeton.edu/researchcomputing/computational-hardware/machine-2/software/ )
> Has anyone experienced this and/or can help me? Please tell me if I provided  insufficient information.


 This is almost certainly a problem with the blas library you have linked to.
Perhaps you could link to Intel's MKL blas instead.


Department of Materials, University of Oxford, Parks Road, Oxford, OX1 3PH, UK
tel: +44 (0)1865 612797                http://users.ox.ac.uk/~oums0549/

More information about the Wannier mailing list