[Wannier] Issues with pw2wannier90

Giovanni Pizzi giovanni.pizzi at epfl.ch
Tue Feb 28 22:37:25 CET 2017

Does pw.x work without problems?

I would check a few things:
1. That the code is not requiring too much memory
2. http://www.quantum-espresso.org/wp-content/uploads/Doc/pw_user_guide/node21.html#SECTION00060090000000000000 and in particular try to recompile with the suggestions of sec and possibly of other sections to see if the error happens e.g. also with -O0
3. Check also if you are properly linking the libraries (lapack, bias) - e.g. if you have an issue similar to here http://www.quantum-espresso.org/wp-content/uploads/Doc/user_guide/node14.html (I would suggest that you try at least another set of libraries, e.g. the internal ones with QE and the ones provided by Mac on the Accelerate framework).

If the error is instead reproducible, doesn’t depend on memory and independent of the libraries, you can try to debug the code to see in which point the code crashes, and we can further investigate if there is a bug.

Let us know the results of what you discover


On 28 Feb 2017, at 22:26, a3almuta at uwaterloo.ca<mailto:a3almuta at uwaterloo.ca> wrote:

Quantum espresso 6.0.


Quoting Giovanni Pizzi <giovanni.pizzi at epfl.ch<mailto:giovanni.pizzi at epfl.ch>>:

Which version of Quantum Espresso are you using?


Giovanni Pizzi
Theory and Simulation of Materials and MARVEL, EPFL

On 27 Feb 2017, at 16:46, a3almuta at uwaterloo.ca<mailto:a3almuta at uwaterloo.ca> wrote:

Hello wannier90 developers and users

First thanks for the recent update to Wannier90 and introducing the symmetry adoptive feature. However, since I have updated my Wannier90 (including updating the pw2wannier90.x in my QE). I have been having an issue with the software. To try the new version I tried to do the MoS2 wannierization again this time with the symmetry adaptive option on. This is the input file to the pw2wannier90:

  seedname = 'MoS2'
  write_unk = .true.
  reduce_unk = .true.
  write_amn = .true.
  write_mmn = .true.
  write_unkg = .false.
  write_dmn = .true.

While it was working before the update, now I am getting this error:

   Error in routine pw2wannier90 (1):
   reading inputpp namelist

so I decided to test the software with the examples provided. I chose the example21 with As_sp. When I ran the pw2wannier90, I got this error during computing DMN:

*** Compute DMN

Number of symmetry operators =    24
    1-th symmetry operators is
    1.0000000      0.0000000      0.0000000
    0.0000000      1.0000000      0.0000000


DMN(d_matrix_wann): nir =       10
     1       2       3       4       5       6       7       8       9      10
DMN(d_matrix_wann) calculated

DMN(d_matrix_band): nir =       10
   Error in routine gather_grid (1):
   do not use in serial execution

   stopping ...

so I decided to comment the dmn calculation but I got another error when computing A:

*** Compute  A

AMN: iknum =       64
Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x100f9aa69
#1  0x100f99e35
#2  0x7fff92aa6529
#3  0x7fff95a89b06
#4  0x10096d4f6
#5  0x10096dd6f
#6  0x10098478d
#7  0x100cb841e

I tried the Cu example but I still got the same two errors.

I am running it on macbook pro machine (v.10.6)

May you please help me fixing this issues, mainly the MoS2 one.


AbdulAziz AlMutairi
The University of Waterloo

Wannier mailing list
Wannier at quantum-espresso.org<mailto:Wannier at quantum-espresso.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quantum-espresso.org/pipermail/wannier/attachments/20170228/82f0ba4d/attachment.html>

More information about the Wannier mailing list