[Wannier] Issues with pw2wannier90

Giovanni Pizzi giovanni.pizzi at epfl.ch
Tue Feb 28 21:47:51 CET 2017

Which version of Quantum Espresso are you using?


Giovanni Pizzi
Theory and Simulation of Materials and MARVEL, EPFL

On 27 Feb 2017, at 16:46, a3almuta at uwaterloo.ca<mailto:a3almuta at uwaterloo.ca> wrote:

Hello wannier90 developers and users

First thanks for the recent update to Wannier90 and introducing the symmetry adoptive feature. However, since I have updated my Wannier90 (including updating the pw2wannier90.x in my QE). I have been having an issue with the software. To try the new version I tried to do the MoS2 wannierization again this time with the symmetry adaptive option on. This is the input file to the pw2wannier90:

   seedname = 'MoS2'
   write_unk = .true.
   reduce_unk = .true.
   write_amn = .true.
   write_mmn = .true.
   write_unkg = .false.
   write_dmn = .true.

While it was working before the update, now I am getting this error:

    Error in routine pw2wannier90 (1):
    reading inputpp namelist

so I decided to test the software with the examples provided. I chose the example21 with As_sp. When I ran the pw2wannier90, I got this error during computing DMN:

 *** Compute DMN

 Number of symmetry operators =    24
     1-th symmetry operators is
     1.0000000      0.0000000      0.0000000
     0.0000000      1.0000000      0.0000000


 DMN(d_matrix_wann): nir =       10
      1       2       3       4       5       6       7       8       9      10
 DMN(d_matrix_wann) calculated

 DMN(d_matrix_band): nir =       10
    Error in routine gather_grid (1):
    do not use in serial execution

    stopping ...

so I decided to comment the dmn calculation but I got another error when computing A:

 *** Compute  A

 AMN: iknum =       64
Program received signal SIGSEGV: Segmentation fault - invalid memory reference.

Backtrace for this error:
#0  0x100f9aa69
#1  0x100f99e35
#2  0x7fff92aa6529
#3  0x7fff95a89b06
#4  0x10096d4f6
#5  0x10096dd6f
#6  0x10098478d
#7  0x100cb841e

I tried the Cu example but I still got the same two errors.

I am running it on macbook pro machine (v.10.6)

May you please help me fixing this issues, mainly the MoS2 one.


AbdulAziz AlMutairi
The University of Waterloo

Wannier mailing list
Wannier at quantum-espresso.org<mailto:Wannier at quantum-espresso.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quantum-espresso.org/pipermail/wannier/attachments/20170228/70a3f654/attachment.html>

More information about the Wannier mailing list