[Wannier] Ubuntu10.04 and LAPACK

Philipp Lucas philipp.lucas at googlemail.com
Tue Oct 4 03:49:21 CEST 2011


I've tried to run Wannier90 on my Ubuntu10.04 64bit using the repository
version of LAPACK and BLAS - unsuccessfully. It compiles without any error.
However, the test cases both fail saying:

"Error in unitarity of initial U in overlap_project"

I found this old post on the mailing list, which is exactly what happened to


I double checked my library paths and build the wannier code again and
again, but nothing helps. Also regardless of the compiler I use (I tried
gfortran and mpif90).

However, when I install ATLAS from the repositories and use ATLAS + LAPACK
and the mpif90 compiler everything works fine.

So, this post is just to confirm that there is a problem to get the
repository versions of LAPACK, BLAS running with Wannier90 in ubuntu.
And also to show how to get it working nevertheless...


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.quantum-espresso.org/pipermail/wannier/attachments/20111004/437d5e6b/attachment.html>

More information about the Wannier mailing list